Tornado Nova stuck "Has pending transactions"

I have a shielded balance on tornado nova that i deposited, but when going to withdrawal/transfer im unable to because it says i have “pending transactions”. There’s no way to see what that might be so i’m stuck, any ideas how to fix?

There shouldn’t be anything pending as the eth was deposited succesfully and shows up.

Hi @0xech0,

Thank you for getting in touch.

Please follow these troubleshooting steps:

  1. Ensure your shielded key is backed up
  2. Clear browser history and cache
  3. Initialize a new VPN instance
  4. Sign in with shielded key
  5. If nothing changes, please repeat steps 1 to 4.

To save your shielded key, go to the shielded key section of docs which you can find here:
https://docs.tornado.cash/tornado-cash-nova/logging-in-tornado-cash-nova

Please let us know how it goes.

Cheers,
Heimdall

1 Like

Ok tried that. Using the shielded key, i get this error message:
Method getAccountBalance has error:

Method getUtxoFromKeypair has error: Events worker method getUnspentData has error: Events worker method getDecryptedEvents has error: undefined

Please try a different device or internet connection.

In order to proceed with the withdrawal accordingly, you’re required to download some data to generate a zksnark proof. With bad internet or VPN, you won’t be able to.

Cheers,
Heimdall

Where you able to fix the error ? Did you try a new device or different internet connect as mentioned above? @0xech0

hey- yep fixed it eventually- not sure if connection speed or what but i tried again a few hours later and it worked fine.

Alright thanks ……………………,?(???